Results 1 to 10 of 10

Thread: How do I change Title tag on site and posts?

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Sep 2009
    Location
    Grand Rapids, Michigan U.S.A.
    Posts
    115

    Default How do I change Title tag on site and posts?

    Hi, could someone please remind me where do I go in Wordpress to change my Title tag for the home page on my site? I've looked in my PHP and can't find it there.

    Also, I want the title tag for my posts so they it will be the same as the post (instead of my site title tag). Any help will be greatly appreciated! Thanks!

    Rich
    I write on personal growth at LifeCompassBlog.com and personal finance at MoneyWisePastor.com

  2. #2
    billdotd Guest

    Default

    To change blog title: Dashboard>Settings>General>edit "Blog Title"

    To change permalinks (I think this is what you want):
    go to Dashboard>Settings>Permalinks, under "Common Settings" choose "Custom Structure" and enter "/%postname%.html"

  3. #3
    Join Date
    Sep 2009
    Location
    Grand Rapids, Michigan U.S.A.
    Posts
    115

    Default

    @billdotd,

    Thanks for reply. Unfortunately, something somewhere is over-riding the Blog Title settings that you referenced (because what I have written here in these settings does not appear on the site). I think it is in the PHP but I can't find it.

    I already had the permalinks set as you just suggested. But it doesn't change the title that shows at the very top of the window (above the URL box)...so we're still missing something here. Any other ideas? Thanks again for taking time to reply!

    Rich
    I write on personal growth at LifeCompassBlog.com and personal finance at MoneyWisePastor.com

  4. #4
    billdotd Guest

    Default

    Are you using an SEO plugin? I use "All in One SEO" and can make changes in its settings panel. There are wildcard options so the header can put the post or page titles into the header...

  5. #5
    Join Date
    Jul 2009
    Location
    Missouri, USA
    Posts
    950

    Default

    Bill is correct, if you're using an SEO plugin, you need to set your blog title in the main settings for the plugin, then use the All in One SEO box below each post/page and add your title there.

    If you're using Headspace, you just add the title and/or site include tags under the settings for post, page, home & front page sections.

    If you are NOT using a plugin, then you need to make sure that you have the title tag in the header.php file for the theme you're using.

  6. #6

    Default

    Rich are you talking about your post and page title or the actual site title when you first visit your website?

  7. #7

    Default

    Rich which Theme are you using? That may have a lot to do with the way things show up

  8. #8

    Default

    One more tool to help you debug wordpress

    http://wordpress.org/extend/plugins/reveal-template/

  9. #9
    Join Date
    Sep 2009
    Location
    Grand Rapids, Michigan U.S.A.
    Posts
    115

    Default Title php help needed

    Thanks everyone for your replies.

    In answer to Bar2K's questions, the theme I use is Thesis, and I'm talking about the site title at the very top of the browser window.

    Here's the latest on my situation:

    I found my header.php file and discovered that I had my site title set as follows:
    -------------------------8<---------------------------------
    <?php
    /**
    * Handle the opening HTML and actions.
    *
    * @package Thesis
    */

    # Added to appease certain plugins which check for this code in this file:
    # wp_head();
    ?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" <?php language_attributes(); ?>>

    <head profile="http://gmpg.org/xfn/11">

    <title>Life Compass Blog | Life Change, Life Purpose & Life-Work Balance How-To's, Tips, Ideas, and Reviews</title>

    <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
    <?php wp_head(); ?>

    </head>

    <body<?php thesis_body_classes(); ?>>

    <?php thesis_hook_before_html(); ?>
    ---------------------8<--------------------------

    I double-checked my blog name and tagline in the WP General Settings and I saw that I had already activated the blog name and tagline in the Thesis Appearance Design Options, but it didn't make any difference. The stuff I had written in my settings did not appear on my site title, presumably because the text above that I highlighted in red was overriding it.

    So this site title appeared as the title in the very top of the browser window for my home page and the pages of my posts.

    I have Greg's High Performance SEO installed, but whatever I had written there in the title sections seemed to make no difference either.

    I searched online to try and find an answer and ran across this:

    <title>
    <?php wp_title('|',true,'right'); ?>
    <?php bloginfo('name'); ?>
    </title>

    So I deleted the red text above, and replaced it with this new text.

    Now, my post titles appear as the page title at the very top of each browser (yeah!), even though I've entered nothing at all in the title sections of the SEO plug-in.

    But, on my home page, only the site name appears, not my tagline. So right now, the only thing yet to do is get my tagline to appear in the title of the browser page.

    Any ideas? Thanks again!

    Rich
    I write on personal growth at LifeCompassBlog.com and personal finance at MoneyWisePastor.com

  10. #10
    Join Date
    Jul 2009
    Location
    Missouri, USA
    Posts
    950

    Default

    Rich, try adding the description tag below the title tag you added:

    <meta name="description" content="<?php bloginfo('description'); ?>" />

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •