Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: STOP! Read Me Before You Upgrade to WP 3.4

  1. #1
    Join Date
    Aug 2009
    Location
    Grand Rapids, Michigan
    Posts
    727

    Exclamation STOP! Read Me Before You Upgrade to WP 3.4

    Hey our super-fab Mod Angie Newton posted a thread over on the Elite side about her blog links breaking after she upgraded to WP 3.4. Turns out she uses this permalink structure: /%post_id%/%postname% as recommended by Lynn. I use it myself, so I helped her troubleshoot.

    It looks like the upgrade to 3.4 breaks the short version of the links. So http://yourdomain.com/1234 will no longer work. You'll have to use the whole thing.

    Just FYI. I'm going to look into it a bit more to see if there's any word from WP. Will post back as I learn more.
    Cindy
    The Educated VA
    www.EducatedVA.com
    Earn a Living Online as a Virtual Assistant - Step by Step VA

  2. #2

    Default

    Thank you so much for checking on this! I tweeted them today but of course I didn't hear anything lol

    I'm not reverting back YET but I will have some broken links out there while I wait. UGH Why do they not check these things before they put out new versions?
    ~Angie~

    Visit Newton's Travels, a couples & multi generational travel blog!

    Twitter|Instagram

  3. #3

    Default

    Quote Originally Posted by cindybidar View Post

    It looks like the upgrade to 3.4 breaks the short version of the links. So http://yourdomain.com/1234 will no longer work. You'll have to use the whole thing.
    Hi there Cindy, I read Angie's thread this morning. I use the custom permalink of /%postname%/ and this seems OK. As a matter of interest, what does /%post_id%/%postname% do?

    I don't normally upgrade as soon as the version is released but I apparently seem to have just done that. At the same time Yoast had an upgrade to his SEO plugin and it would appear that the last post on my Blog does not show if the Yoast plug in is activated. If I deactivate it, the post shows up??

    I've put a message on the WP Forum, but it'll be a while since I hear back, I guess. Do you have any thoughts on why this might be? All ideas gratefully received. BTW - is it possible to revert back to the previous WordPress version?

    Caroline

  4. #4
    Join Date
    Jul 2009
    Location
    The Other Washington(State)
    Posts
    405

    Default

    I agree with Angie that testing for custom permalinks problems should be a high priority with WP before releasing any upgrades

  5. #5
    Join Date
    Jul 2009
    Location
    The Other Washington(State)
    Posts
    405

    Default

    CarolineJ I would hang in there as Yoast is usually on top of this sort of thing and will issue a upgrade or whatever is needed to clear this up. Also I would post your problem on his site. http://yoast.com/wordpress/seo/

  6. #6
    Join Date
    Jul 2009
    Location
    The Other Washington(State)
    Posts
    405

    Default

    Please do note that this problem presently applies only to any WordPress users who have used a custom setting for permalinks. Not all WP upgrades are Security upgrades and as shown it often pays to wait and see if problems are created by the upgrade. Reverting back to a previous version is not as easy( as most upgrades are.) to accomplish.

  7. #7
    Join Date
    Aug 2009
    Location
    Grand Rapids, Michigan
    Posts
    727

    Default

    Just to be clear, not ALL custom permalinks are broken. It's ONLY a problem in a very specific circumstance. If you have the permalinks set to /%post_id%/%postname% so your URLs look like this: yourdomain.com/1234/your-post-title - That alone is fine, and will continue to work.

    The problem is that one of the reasons to use this permalink structure is so you can shorten the above link to just yourdomain.com/1234. That link should still take you to the post. With this update, though, the short version isn't working any more.

    What's not clear to me is if this is a supported feature in WP, or just a handy side-effect that simply doesn't work any more.
    Cindy
    The Educated VA
    www.EducatedVA.com
    Earn a Living Online as a Virtual Assistant - Step by Step VA

  8. #8
    Join Date
    Aug 2009
    Location
    Grand Rapids, Michigan
    Posts
    727

    Default

    WooHoo! Thanks to Regina Smola and Gary Cornelisse, we have resolved this with a small hack to the .htaccess file.

    Remember, you only need to do this if you're giving people a link to your blog that looks like this: http://yoursite.com/123

    Okay - here's the .htaccess code (back up your files first, please):

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RedirectMatch 301 ^/(\d+)/$ http://YOURDOMAIN.com/?p=$1
    RedirectMatch 301 ^/(\d+)$ http://YOURDOMAIN.com/?p=$1

    </IfModule>
    Cindy
    The Educated VA
    www.EducatedVA.com
    Earn a Living Online as a Virtual Assistant - Step by Step VA

  9. #9
    Join Date
    Jul 2009
    Posts
    475

    Default

    Ok, I think I am about to faint. .Htaccess files make me crazy. I have yet to conquer them. Cindy, are you up for fixing this for me?
    Natalie Akpele

    Sleeping babies... Happy Parents!
    http://www.slumberosity.com

  10. #10
    Join Date
    Jul 2009
    Location
    Houston, TX
    Posts
    858

    Default

    @Caroline -- do you by any chance have WP Super Cache? You might try clearing your cache. I also had this issue before upgrading WP with the setting to not cache for known users. As soon as I deselected that setting, the issue cleared up.
    Christine Cobb
    Confused about Aweber, selling products and other technical challenges? [read more...]

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •